HCL Domino: Remote-Server-Einrichtung bricht bei 20% ab (Update 15.04.2021)

von Thomas,
assono GmbH, Standort Kiel,

Eine - zugegebener Maßen seltene - Konstellation und eine Einrichtungsroutine, die ohne hilfreiche Hinweise oder Protokolle einfach ihre Arbeit beendet: Das sind die Zutaten für üble Kopfschmerzen (wegen des häufigen, heftigen Kopf-mit-Tisch-Kontaktes). ;-)

Die Situation war wie folgt: Ein neuer Domino-Server sollte installiert werden. Die Maschine steht in einem neuen Standort und läuft unter Linux. Der "alte" Domino-Administrations-Server ist direkt über das Internet an einer festen IP-Adresse mit im DNS eingetragenen Namen erreichbar.

Der neue Server wird installiert, Sprachpaket eingespielt und im Verzeichnis /local/notesdata mit /opt/hcl/domino/bin/server -listen als Benutzer notes gestartet. Soweit, so Routine.

Auf einem Windows-Rechner des Administrators, der beide Server erreichen kann (den alten direkt über das Internet, den neuen über ein gestartetes, verbundenes VPN) starte ich die Remote-Server-Einrichtung aka Remote Server Setup.

Kontakt zum neuen Server wird aufgebaut, die dort hinterlegte ID-Datei kann ich auswählen, und stelle auch die anderen Rädchen alle richtig ein. Dann läuft die Konfiguration los und bricht zuverlässig immer wieder bei 20% ab. :-(

Viele Versuche und ein, zwei hervorragende Tipps eines Kollegen später finde ich dann die Lösung:

Der neue Server versucht den alten nicht nur über die eben in der Remote-Server-Einrichtung eingestellte IP-Adresse bzw. den dort eingetragenen Namen zu erreichen, sondern verwendet zur Abwechslung auch mal den vollqualifizierten Hostnamen, der im Server-Dokument für den alten Server eingetragen ist. Dieser Name ist aber leider nur lokal in dem dortigen Standort auflösbar. Pech gehabt. Abbruch...

Die Lösung war, den vollqualifizierten Hostnamen aus dem Server-Dokument zusammen mit der festen, von außen erreichbaren, nummerischen IP-Adresse des alten Servers zumindest für die Zeit der Konfiguration in die /etc/hosts des neuen Servers einzutragen. So lief die Server-Einrichtung glatt durch. Danach konnte ich die Zeile aus der /etc/hosts sofort wieder entfernen und das Verbindungsdokument wird fürderhin genutzt, damit der neue Server den alten für Routing und Replikation findet.

Update (15.04.2021)

Nicht einmal ein Jahr später hatte ich gestern das gleiche Problem wieder. Die Lösung sowie diesen Blog-Eintrag hatte ich leider schon komplett vergessen. Gut, dass es Suchmaschinen gibt. 😊

Ich habe diesen Artikel aber nicht sofort gefunden, weil ich nach anderen Details gesucht hatte. Die ergänze ich einfach mal nachträglich, in der Hoffnung, nächstes Mal schneller auf diese Lösung zu stoßen:

Domino, Remote-Server-Setup, Remote Setup

Ausschnitt aus setuplog.txt

message=The server is not responding. The server may be down or you may be experiencing network problems. Contact your system administrator if this problem persists.
command=16
status=2055
Fachbeitrag HCL Domino Administration Für Entwickler

Sie haben Fragen zu diesem Artikel? Kontaktieren Sie uns gerne: blog@assono.de

Sie haben Interesse an diesem Thema?

Gerne bieten wir Ihnen eine individuelle Beratung oder einen Workshop an.

Kontaktieren Sie uns

Weitere interessante Artikel

Sie haben Fragen?

Wenn Sie mehr über unsere Angebote erfahren möchten, können Sie uns jederzeit kontaktieren. Gerne erstellen wir eine individuelle Demo für Sie.

assono GmbH

Standort Kiel (Zentrale)
assono GmbH
Lise-Meitner-Straße 1–7
24223 Schwentinental

Standort Hamburg
assono GmbH
Bornkampsweg 58
22761 Hamburg

Telefonnummern:
Zentrale: +49 4307 900 407
Vertrieb: +49 4307 900 402

E-Mail-Adressen:
kontakt@assono.de
bewerbung@assono.de